Skip to content

Commit

Permalink
libyder: add package, bump ulfius and orcania ver
Browse files Browse the repository at this point in the history
Signed-off-by: vidplace7 <[email protected]>
  • Loading branch information
vidplace7 committed Dec 6, 2024
1 parent 56a2f61 commit 4b3e943
Show file tree
Hide file tree
Showing 3 changed files with 62 additions and 6 deletions.
4 changes: 2 additions & 2 deletions libs/liborcania/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -6,12 +6,12 @@
include $(TOPDIR)/rules.mk

PKG_NAME:=liborcania
PKG_VERSION:=2.3.0
PKG_VERSION:=2.3.3
PKG_RELEASE:=1

PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/babelouest/orcania/tar.gz/v$(PKG_VERSION)?
PKG_HASH:=b1b5550523164eca0f59099e843177684c5017c6088284123880cffd4c6dbbde
PKG_HASH:=e26947f7622acf3660b71fb8018ee791c97376530ab6c4a00e4aa2775e052626

PKG_MAINTAINER:=Toni Uhlig <[email protected]>
PKG_LICENSE:=LGPL-2.1-or-later
Expand Down
21 changes: 17 additions & 4 deletions libs/libulfius/Makefile
Original file line number Diff line number Diff line change
@@ -1,12 +1,12 @@
include $(TOPDIR)/rules.mk

PKG_NAME:=libulfius
PKG_VERSION:=2.7.10
PKG_VERSION:=2.7.15
PKG_RELEASE:=1

PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/babelouest/ulfius/tar.gz/v$(PKG_VERSION)?
PKG_HASH:=616c5df99584071461a1285dd7155883f7d2b94abf0931038feeebd3da3a6def
PKG_HASH:=19cf789b2af1919b69f77c7701237bfc318a9781ec657b68fd4b6ffa9d53f111

PKG_MAINTAINER:=Toni Uhlig <[email protected]>
PKG_LICENSE:=LGPL-2.1-or-later
Expand Down Expand Up @@ -42,6 +42,14 @@ $(call Package/libulfius/default)
PROVIDES:=libulfius
endef

define Package/libulfius-yder
$(call Package/libulfius/default)
TITLE+= with yder support
VARIANT:=yder
DEPENDS:=+libmicrohttpd +libcurl +liborcania +libyder
PROVIDES:=libulfius
endef

CMAKE_OPTIONS += \
-D_GNU_SOURCE=ON \
-DDOWNLOAD_DEPENDENCIES=OFF \
Expand All @@ -50,8 +58,6 @@ CMAKE_OPTIONS += \
-DWITH_CURL=ON \
-DWITH_JANSSON=OFF \
-DWITH_STRSTR=ON \
-DWITH_YDER=OFF \
-DSEARCH_YDER=OFF \
-DCMAKE_BUILD_TYPE=Release

ifeq ($(BUILD_VARIANT),gnutls)
Expand All @@ -60,5 +66,12 @@ else
CMAKE_OPTIONS += -DWITH_GNUTLS=OFF
endif

ifeq ($(BUILD_VARIANT),yder)
CMAKE_OPTIONS += -DWITH_YDER=ON -DSEARCH_YDER=ON
else
CMAKE_OPTIONS += -DWITH_YDER=OFF -DSEARCH_YDER=OFF
endif

$(eval $(call BuildPackage,libulfius-gnutls))
$(eval $(call BuildPackage,libulfius-yder))
$(eval $(call BuildPackage,libulfius-nossl))
43 changes: 43 additions & 0 deletions libs/libyder/Makefile
Original file line number Diff line number Diff line change
@@ -0,0 +1,43 @@
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#

include $(TOPDIR)/rules.mk

PKG_NAME:=libyder
PKG_VERSION:=1.4.20
PKG_RELEASE:=1

PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/babelouest/yder/tar.gz/v$(PKG_VERSION)?
PKG_HASH:=c1a7f2281514d0d0bba912b6b70f371d8c127ccfd644b8c438c9301a0fd4c5f2

PKG_MAINTAINER:=Austin Lane <[email protected]>
PKG_LICENSE:=LGPL-2.1-or-later
PKG_LICENSE_FILES:=LICENSE

PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)/yder-$(PKG_VERSION)
CMAKE_INSTALL:=1

include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/cmake.mk

define Package/libyder
SECTION:=libs
CATEGORY:=Libraries
TITLE:=Logging library written in C.
URL:=https://github.com/babelouest/yder
DEPENDS:=+liborcania
PROVIDES:=libyder
endef

CMAKE_OPTIONS += \
-DWITH_JOURNALD=off \
-DCMAKE_BUILD_TYPE=Release

define Package/libyder/description
Simple and easy to use logging library. You can log messages to the console, a file, Syslog, journald or a callback function.
endef

$(eval $(call BuildPackage,libyder))

0 comments on commit 4b3e943

Please sign in to comment.