Skip to content

v0.17.0

Compare
Choose a tag to compare
@eunjae-lee eunjae-lee released this 06 Mar 15:08
· 224 commits to main since this release
0f8a248

0.17.0 (2020-03-06)

BREAKING CHANGE

BREAKING CHANGE

This version introduces some breaking changes.

  • In your ship.config.js, rename pullRequestReviewer to pullRequestReviewers (which accepts only an array of strings).

  • In your ship.config.js, rename pullRequestTeamReviewer to pullRequestTeamReviewers (which accepts only an array of strings).

  • releaseStart for Slack message has been removed. If you'd like to have it back, please create an issue and let's discuss.

  • The default value of testCommandBeforeRelease is now undefined. It used to be ({ isYarn }) => isYarn ? 'yarn test' : 'npm run test'. This change assumes many of you already run tests with CI services when you create pull requests. With the previous config, Ship.js unnecessarily ran tests before release. If you'd like to have it back, add some config like the following:

testCommandBeforeRelease: ({ isYarn }) => isYarn ? 'yarn test' : 'npm run test',

Bug Fixes

  • setup: do not write ship.config.js if not necessary (#705) (82f8cbc)

  • setup: fix wrong config(packagesToBump, packagesToPublish) for monorepo (#701) (0590a38)

  • clean up reviewer related configs (#707) (833d684)

  • allow @(a|b|c) syntax for packagesToBump and packagesToPublish (#702) (de9083c)

  • remove releaseStart hook for slack message (#703) (2a9502b)

  • create CHANGELOG if missing (#697) (72cb4ec)

  • empty testCommandBeforeRelease by default (#696) (34753b0)

  • shipjs-lib: exclude dependencies from final bundle (#651) (f6ec4cf)

  • check nullable value for reviewers (#709) (df7c0be)