Skip to content

Releases: SoySauceLab/CollectionKit

XCode 10.2 & Swift 5 support

03 Apr 05:30
Compare
Choose a tag to compare
  • Fixed an issue with provider identifier collision. #129 @dishcool

2.3.0

13 Dec 23:50
Compare
Choose a tag to compare

Changes

  • Add AutoLayoutSizeSource (#110) @Tylerian
  • cleanup simple view provider (#108)
  • Class based size source (#107)
  • Performance improvement with cell reuse (#100)

2.2.0

26 Sep 23:39
Compare
Choose a tag to compare
  • Xcode 10 & Swift 4.2 support

2.1.0

03 Sep 04:45
Compare
Choose a tag to compare
  • fix issues caused by conflicting identifiers (#85) @Banck
  • change WaterfallLayout default parameters' values to align with other layouts
    • from init(columns: Int = 1, spacing: CGFloat = 10)
    • to init(columns: Int = 2, spacing: CGFloat = 0)
  • include WobbleAnimator into the podspec as a subspec.
    • pod "CollectionKit/WobbleAnimator"
  • BaseSimpleAnimator
    • rename BaseSimpleAnimator to SimpleAnimator to align with SimpleLayout
    • rename updateAnimationDuration to animationDuration
    • add var animationOptions: UIViewAnimationOptions
    • add var useSpringAnimation: Bool
    • add var springDamping: CGFloat
  • FadeAnimator
    • add var alpha: CGFloat
  • ScaleAnimator
    • change its superclass from BaseSimpleAnimator to FadeAnimator
    • add var scale: CGFloat

Example project:

  • move examples into its own project. and switch from Carthage to Cocoapods.

2.0.2

08 Aug 07:52
Compare
Choose a tag to compare
  • Fix unexpected UIScrollView behavior (#77) @humblehacker
  • ComposedHeaderProvider tapHandler index fix (#83) @Fabezi
  • Support tapHandler in SimpleViewProvider.

2.0.1

23 Jun 08:00
Compare
Choose a tag to compare
  • Fix a crash when using CollectionKit with other types of UIScrollView.

2.0.0

23 Jun 04:58
ad1ed87
Compare
Choose a tag to compare

Focus of v2.0 will be towards API cleanliness & solves pain points with v1.0+

Main feature of v2.0:

  1. Complete renaming of classes
    • With v1.0, naming of the classes weren't given enough thoughts. Names like CollectionProvider, ViewCollectionProvider, ViewProvider, DataProvider, etc.. are all quite confusing to use.
  2. Removing confusing initializer
  3. Sticky Header Support
  4. Initial support for mixed data type
  5. Layout cleanup
  6. Internal architectural & performance improvement

Please checkout the migration guide for updating from v1~

1.3.1

22 Jun 09:03
8a5f5b1
Compare
Choose a tag to compare

1.3.0

12 Apr 04:01
Compare
Choose a tag to compare
  • dequeue by Type (#39) @hiroshihorie
  • Convert the Convenience Inits to designated Inits to use them for subclassing. (#47) @Narsail
  • Add in CollectionViewCollectionProvider. (#53) @jindulys
  • Add super designated initializer call to SpaceCollectionProvider. (#52) @jindulys
  • Scroll performance improvement
    • identifiers will now be cached and won't be used to calculate differences if there are no visible index change.
  • CollectionView.activeFrameInset is removed.
  • VisibleFrameInsetLayout is added to replace activeFrameInset.
    • To achieve the same effect as activeFrameInset, use:
    SomeLayout().insetVisibleFrame(by: activeFrameInset)
  • CollectionComposer reload performance is improved, especially for deeply nested sections. Previously each composer have to created an array of length of all items contained inside the composer during reload. and now it doesn't.

1.2.1

22 Dec 19:43
Compare
Choose a tag to compare
  • Make CollectionViewProvider.reuseManager public: 69c6f70